iDRAC Java connection error – work around for old iDRAC versions (6,7,8)

The issue is unsupported algorithms by the iDRAC system. iDRAC6 still has yet to fix this (9/3/2018) but is resolved on 7+ AFAIK

There is only a single item to remove from your java.security file to retain the IDRAC6 functionality.

jdk.tls.disabledAlgorithms=SSLv3, RC4, MD5withRSA, DH keySize < 1024, \
    EC keySize < 224, DES40_CBC, RC4_40, 3DES_EDE_CBC

need to be changed to

jdk.tls.disabledAlgorithms=SSLv3, RC4, MD5withRSA, DH keySize < 1024, \
    EC keySize < 224, DES40_CBC, RC4_40

Effectively it’s only `3DES_EDE_CBC` instance should be removed from this directive and nothing more.

Additionally i would reccommend you make the following change in the IDRAC
webpage:
iDRAC Settings –> Network/Security –> Services: Change the SSL
Encryption to 256-bit or higher.
This doesn’t negate the above change thats needed in your java.security
file until Dell makes a Fix.